Google reviews not loading

Thank you so so much!!
I really appreciate your help!
Have an awesome day!

No sweat!

If anything comes up, please feel free to contact us!

Have a great day :wink:

1 Like


We have a similar issue, after entering the address/place ID and selecting our location no reviews come up in the widget preview. It says “No reviews found. Please make sure the source is correct, that it has reviews and that filter settings do not exclude all the reviews.” I have tried adjusting all the filters.

Our Place ID is ChIJcUgSy0tCZIgRIXCt22s1j-A

Thank you for your help.


Hello @WST and welcome to Elfsight Community :heart:

I am deeply sorry for the interruption in our Google Reviews widget’s work and for the inconvenience this is causing you.

Unfortunately, our Google Reviews widget is experiencing some technical issues at the moment.

Our developers are already working on a solution. After the fix is ready, it will be automatically applied to your widget, you won’t have to do anything on your end.

I will get back to you as soon as I receive any news from the developers.

Thank you for understanding and for sticking with us!

Can you please update this thread when the fix is applied? I’ve subscribed to get alerts. Thanks.

1 Like

Hello @AJ11! We are so happy to see you here! Welcome to Community :heart:

I am terribly sorry for all the inconvenience caused!

Sure thing, we’ll keep you updated here and in this topic. You can also check it.

Thank you for your patience and understanding :pray:

Hello guys @AJ11 @WST!

Great news! We’ve fixed the issue!

Could you please check your widgets and let me know if everything is fine?

The widget is working! Thank you.

1 Like

Mines is not. I’ve already emailed support. :slight_smile:

1 Like

Hello @AJ11!

I am so sorry for this inconvenience :pensive: I’ve updated the source and everything is working fine now.

Please check your widget and let me know how it works for you.

Hi @Max!

I have a similar issue with google reviews. Could you please check this ID:

Appreciate your help.

1 Like

Hello @Bibinyyaz! Happy to see you here! Welcome :heart:

I am terribly sorry about this inconvenient situation!

I’ve forwarded your request to our devs! I’ll immediately get back to you as soon as I receive any updates.

Thank you for understanding :pray:

1 Like

@Bibinyyaz the issue is fixed, thanks a lot for your patience!

Could you please check and let me know if everything’s fine on your end?

1 Like

Yes, it works perfectly! Thank you very much!

Great! Many thanks for the update!

Should any help needed, we’re always here :slight_smile:


I have the same issue for the review not loading and below is my google embed:

Thank you

1 Like

My Google Review are not loading,
I checked all parameters are OK;
I created a 2nd widget to make sure, still not loading,
Is there a way to fix?

1 Like

Hello guys @Lee4 @user2751 ! Welcome to Elfsight Community :wave:

I am terribly sorry for the frustration caused by the issue!

I’ve forwarded your requests to our devs and, hopefully, they’ll come up with a solution really soon!

I’ll immediately get back to you as soon as I receive any news!

Thank you for your patience and understanding :pray:

Guys @Lee4 @user2751!

Your widgets are fixed!

Could you please check them and let me know how they work for you?

Same issue here: 223911738133401641

It says no reviews found.

1 Like