Email replies no longer going to email provided on form

We’ve been using form builder for months and until recently we could reply to the emails we receive from the form submissions and it would go to the email address provided by the customer in the form. Now when we hit reply it goes to ‘notifcations@elfsightmail.com’.

The main reason we chose and paid for elfsight was the ability to reply to the customer email address easily. Can anyone help me get this resolved?

Many thanks

Hello @user551! We are happy to greet you at Elfsight Community :wave:!

I am so sorry that you’ve faced an issue using our app!

I’ll be happy to help you!

During the recent Form Builder app update our Reply to function (that allows you to reply directly to your customers via email) has undergone some changes. And unfortunately, Reply to settings in some widgets got reset to default, we sincerely apologize for this!

I’ve just manually set your widget, so that the reply goes directly to the customer, who submitted the form. Here’s how I did it:

  • To reply directly to the customer, who submitted the form, the field ID of the email field needs to be added to Reply to section in the Additional Mail Setting.

  • To find the Field ID, please go to Build Form tab → Email field → It will be at the bottom of the list.

The Field ID gets generated based on the text in the Label field. If this field is empty, the ID gets generated based on the Placeholder field.

As you can see from screenshots above, your widget has Label field with “Your email address?” text, so the Field ID of this email field became [your-email-address?]. I’ve added the correct Field ID [your-email-address?] to Reply to section, and now when you reply to the submissions sent from this widget, the replies will go to the clients as well.

Please, let me know if everything works fine now!

If the issue still persists, please let me know, I’ll be delighted to help!

1 Like