Content Security Policy

I have the following error code within my console:
Refused to connect to ‘’ because it violates the following Content Security Policy directive

I would like to know what that url’s purpose is, reason being that, I’m concerned if it’s a url that is safe to white list, within my CMS

1 Like

Hello @user2100 and welcome to Elfsight Community!

I am so sorry for all the frustration caused!

Could you please provide me with a direct link to the webpage where this occurs?

@user2100 I’ve checked your website and couldn’t find the error “Refused to connect to ‘”.

However, I see another error:

If you still have the first error, could you please provide me with a screenshot of what you see.

In case you see the issue from my screenshot, we’ll be happy to check everything for you.

The whatsapp widget is being used on the website.

1 Like

Hi @user2100!

I’ve checked the homepage and, unfortunately, couldn’t catch the same error.

Could you please specify the webpage where it occurs?

It occurs on the entire website

@user2100 I’ve consulted with our devs regarding this issue. The issue source is panorama.js and it’s not anyhow connected to our widget.

The text of the error says that loading of such content is prohibited due to the Content Security Policy directive. * is one of its values - it means that the download of the corresponding content from a domain ending in ‘’ is not blocked.

You can check it by blocking our platform (platform.js). This error still occurs:

Please let me know if this explains things or if you have any other questions.

My apologies, the problem is related to a different library from another widget provider.

The next question is, how come the WhatsApp window expands automatically when loading a webpage.
This seems to happen occasionally not all the time.
It happens when opening any webpage.

Hello @user2100!

The reason why the Chat Bubble didn’t open right away is Open Chat Triggers. You had triggers Time on Page: 10s and Time on Site:10s, that’s why chat bubble appeared after 10 seconds:

I’ve changed it to 0 s and now the chat bubble appears straightaway. You can find this settings by following these steps: Settings tab- Open Chat triggers:

Could you please check it and let me know if everything is fine?

Originally “Time on Page” and “Time on Site” were both set to 0 and the window would automatically open up.
Changing those settings to 10s, did not affect it as the window would open up before 10s have elapsed.

The goal here is to not have the window open automatically but rather only open when the user has clicked on the “Chat with us” button.
So I do not want the window to automatically open up at all

@user2100 I am so sorry for misunderstanding :pensive: Please accept my sincere apologies!

Unfortunately, there is no option to not open Chat Bubble automatically.

I absolutely agree that this feature would be really useful, and we have such a request on our Wishlist. Please vote for this feature to get a notification upon its release here - Have chat not open automatically after time trigger - #2 by Helga

If any questions come up, please feel free to contact us. We’ll be more than happy to help!

Have a nice day :wink: