Google Reviews widget breaking website functionality on Google Chrome mobile browser


I installed a Google Reviews widget on my website, and it works perfectly in a Google Chrome desktop browser. On mobile, Firefox and Samsung internet browser work, as well. However, when using Google Chrome on mobile, the widget breaks the functionality of the website–it increases the width of the site and the lightbox photos don’t open properly. Removing the widget solves the issue, but of course I’d like to keep the widget :smile: Any help is appreciated!

My website is Thank you!

1 Like

Hi there @JoeM :wave:

I’ve checked your website using Google Chrome and the widget looks fine on my side:

Could you please check it out and let me know if it’s fine now?

If the issue still persists, please try to check your website in incognito mode. In case the issue still persist, please specify your device and browser version and send me a screenshot of the issue.

I’ll be happy to investigate it for you :slightly_smiling_face:

Hi @Max ,

Thanks for your response. Here’s how it looks on my end:

I tried incognito on Chrome Mobile and it does fix the issue! Please advise.

Thank you,


1 Like

Got it, thanks!

Please try to clear cache and cookies of your browser and let me know if it helped :slightly_smiling_face:

Just tried it and unfortunately it didn’t fix the issue. At least it seems to work on other visitor’s mobile Chrome browsers :slightly_smiling_face:

1 Like

The screenshot from your previous message was made in incognito mode, right?

If it is, could you please send me a screenshot or a video screencast of the issue in the usual mode?

The screenshot was in regular mode. I’m unable to screenshot when in incognito mode.

I’m not able to upload a screen capture here, so here’s a link to it: Screen_Recording_20240611_150348_Chrome.mp4 - Google Drive

Thanks again!

1 Like

Thank you!

I’ve talked to the devs, and they’ve confirmed that the issue might occur because of your toolbar and visible only to you.

To fix it on your end, please add this code to the Custom CSS field on the Style tab of your widget’s settings:

.eapps-widget-toolbar {
  display: none;
1 Like

Awesome, that fixed it! Thank you so much for your help!


It wasn’t a problem at all :wink: