TikTok Feed not showing

@Helga
My feed is down again and I am a couple of days away from launching this site. How long do you think it will be until fixed?

@Nightowl, we’re extremely sorry for this another interruption :sweat:

Usernames should get fixed any time soon, our developers are about to complete a fix. As for the hashtags, unfortunately, we’ll need more time to bring them back, but we’re doing everything possible.

Thank you so much for your patience :pray:t2:

So… it was working fine 2 days ago and is now broken again…

I have to say this getting rather frustrating. We pay a premium for the plugin (that didn’t have a single issue when I was evaluating it before purchasing) then as soon as I purchase, it starts getting all of these bugs?

Same here, just got it working yesterday after deleting htaccess and today i’m having the same issue… seriously planning on finding another tiktok option

I’d be interested in what you find

Hello @Nightowl, @Rafael! My apologies for the long wait and for these troubles with TikTok :pray:t2:

I do have some news regarding this situation, and I wish it was something more encouraging.

As you might already know, our TikTok Feed widget uses cache to make it load faster and to reduce the server load, so it doesn’t request TikTok each time someone browses your feed. Instead, it requests TikTok once in every 24 hours , pulls in the images by the specified criteria, stores them in the cache, and displays them from the cache. After the cache is expired, the widget requests TikTok for the posts again, and that’s when the new ones make it to your feed.

However, TikTok Feed won’t request TikTok for new data if the widget doesn’t get loaded on your page. In other words, it needs someone to visit the page with the widget in order for it to start the updating process. Once the widget gets loaded on your website, it sends a request to the server → the servers determines, how long it’s been since the last update → if it’s been more than 24 hours , the server runs the command to update the source. It might take some time to update the source. In the meanwhile, the widget doesn’t yet have new thumbnails’ URLs, but old thumbnails URLs are not valid anymore, which causes the error.

As a result, such issue with empty thumbnails can occur when the website traffic gets low.

The good news is that our developers are already working on a solution to this and hopefully, they will be able to fix this issue very soon.

I totally understand that I’ve brought nothing but yet another frustration, and words fail me on how to express how sorry I am about all of this.

I’ve checked your widgets and they should work correctly now. And if there’s anything else I could do for you, please don’t hesitate to hit me up.