Podcast widget - unable to reduce size on mobile on a wix website

  • Issue description:

I’m unbale to reduce the size of the poscast widget in mobile, it seems not to be responsive (the font size also looks the same, not only the podcast image)

I’ve tried this one:

but it doesn’t work.

1 Like

Hi @Tony_Arad_Felik :wave:

Your request is now with our devs! I’ll get back to you once the solution is provided :slightly_smiling_face:

In case you’d like to reduce the widget’s width, you can use this code:

@media (max-width: 500px) {
  .elfsight-app-a8fec367-f80b-48d1-9fd7-cda367aa897b {
    width: 150px !important;

Here is how it looks:

Also, you can reduce the widget’s scale using another code:

@media (max-width: 500px) {
  .elfsight-app-a8fec367-f80b-48d1-9fd7-cda367aa897b {
    scale: 0.5;
    position: absolute;
    top: -260px;
    left: -150px;

One of these codes should be added to the Custom CSS field on the Style tab of your widget’s settings.

However, I’d like to mention that the widget doesn’t look responsive due to the Wix iframes. To resolve this issue, you can reinstall it avoiding iframes or stretch the iframe to give more space for the widget.

Please let me know if this explains things or if you have any further questions :slightly_smiling_face:

Hi, thanks for the reply, however, it doesn’t work.
the second CSS code is colliding with Wix’s code somehow and prevents from the page to load.
The first CSS doesn’t affect much.
The idea is that the podcast should be much smaller in mobile view. you can see in the example you sent that the first episode picture and the font are much more bigger than the main site photo (in mobile)
Even without Wix, in your sandbox, the mobile view doesn’t look good:
If there’s no other solution, I would have to uninstall the widget

Please advise

@Tony_Arad_Felik I got your point! This issue occurs because of the iframes. We recommend you reinstall your widget avoiding iframes.

Could you please check this workaround and let me know if it helped?