Google Reviews Not Loading | Help Needed


I’m having difficulties with getting Google Reviews to load for a client’s Elfsight Google Reviews Widget. After configuring the widget in Elfsight, I am receiving a ‘No reviews found’ message.

Below is a link to their Google My Business listing:
Procenko Team (Google)

Below is a link to a webpage where the widget is placed:
Example page

I’ve experimented with all of the widget customization options, but have not had any luck. See below for an example screen capture. I’ve tried other business listings, and they’ve all worked so far. Any and all help would be highly appreciated.

1 Like

Hello @Dragan and we are happy to see you in the best place on the Earth :earth_africa: Welcome to Elfsight Community :rocket: :heart:

I need to inform you that at the moment, our Google Reviews widgets are experiencing some difficulties. We are doing all our best to fix it globally as soon as possible!

However, I am glad to inform you that we’ve fixed the issue for you :slightly_smiling_face:

Could you please check it and let me know if everything is fine on your side?