Age Verification widget pops up too much

Every time you go to a new window within the site, the age verification keeps popping back up. It’s an alcohol brand so we need it when folks first arrive, but not every time they navigate to a new page within the site. Someone help!


Hi @Jose1, happy to see you on our forum! :slight_smile:

I’ve checked your widget, and it seems the cause of the issue is the Remember Visitor option, which is set to 0 days. That means, that a new user sees the popup every time they visit your homepage.

Could you please try to change the value for Days option and let me know if it helped?



Thanks. I’ll try that. But also, wondering if that affects when I get on the site. Then if I go to another page on the site, the pop up pops up again.

Hi @Jose1, thank you so much for your patience!

I’ve just got a reply from the developers that the functionality has been altered a bit: now if you set the Remember Visitor Days option to 0, the widget will never ever pop up for the same user.

Thus, the widget will not get appeared for the same user twice.

Please let me know if it helped or if you have other questions :slight_smile:

Thank you!

1 Like

Hello Helga,
my widget still pops up every time I go to another subpage… :frowning:
do you know if the issue was solved?

Thanks a lot in advance!

1 Like

Hi @jozef, happy to welcome you in our community!

I’m so very sorry about this experience, I’m going to explain things and provide a solution for you here.

Based on the requests we were receiving, Day = 0 option confused our users, as most of them expected it not to remember a site visitor at all, which is quite understandable. In order to make things transparent, we’ve changed its behaviour to show the widget on every page.

However, your use case is also supported – just pick 365 in the Days section and you’re good :slight_smile:

@Jose1 In case this is a crucial change for you, please change your ‘Days’ setting as well so that your widgets keep working as they should.

Please let me know if it helped. And my apologies that I didn’t update you here as soon as this change was implemented :sweat:

Hi Helga,
now it works as expected, thanks a lot!

1 Like

@jozef thank you for the update, happy to hear that you’re good! :heart_eyes: