Add subject email signup

Share your use case and provide as many details to support your idea as possible:
It would be very helpful when the Subject of the email that people send when they signup via email, is automatically filled, so I know for what event they signup.


Hi there and welcome aboard :wave:

Glad to tell you that it’s possible to automatically fill in the Subject field when signing up for an event.

We’ve added a subject parameter with the name of the event to the email link of all events in your widget and now the event name is automatically added to the subject field:


When the new events are created, just add the subject parameter with the event name to the email link.

Check it out and let me know how it worked :slightly_smiling_face:

Wow that is super fast! Amazing, thank you so much!!


Great! You are very welcome :wink:

In the meantime, we’d really appreciate itl if you could check out the Event Calendar category in the Wishlist and vote your favorite ideas. It would be incredibly helpful for the development of our widgets and services.

And of course, feel free to share your own ideas too!

1 Like

Hi Max,

I have another issue that would be great to be solved.

I am working with Outlook on my phone and desktop.

When clicking the SignUp buttons on my event calendar, I won’t be directed to Outlook, but to Apple Mail which I don’t have on my phone or desktop. I should be able to be directed to the default mail program on my device I would say?

Please let me know what to do to solve this issue?

Thank you! Nicole

1 Like

Hi @user10832 :wave:

I’ve checked your website from different devices and there is no issue on my end. The default mail service (Outlook) is opened when clicking on the Sign Up button.

If I understood correctly, you are using Apple devices. In this case, could you please check which mail service is set by default on your device and send me a screenshot of what you see?

Here are the steps for Macbook: Applications > "System Preferences > Mail

I think that was the problem indeed, I have added Outlook as defaults where you have said, and it works now!

Thank you again!


No problem :slightly_smiling_face:

If anything else comes up, we’ll be happy to help!