My Business Name is not searchable


I am unable to find my business [Trades R Us NSW] on the search string to add the widget.
I also tried using the Google Business ID and that didnt work.



Hi @R_Kaysar and welcome to Community :heart:

I’ve added your Google Place ID (ChIJE821TN2tEmsRkTb85J7QTA) and it’s working fine.

At the moment, you have only 1 review without text, that’s why it’s not displayed.

If you want to show this review, you need to click on Filters and disable Show Reviews only With Text setting:

Please let me know if it helped or if you have any other questions :slightly_smiling_face:

1 Like

Max, this is the wrong business.

Trade Marks R Us is another business.

My Business is Trades R us NSW


1 Like

@R_Kaysar I am sorry for this misunderstanding!

I’ve tried to find your Business in a Google search, but, unfortunately, it’s not displayed for me.

I see that your Business doesn’t have a physical address. In this case, you need to follow these steps:

  1. Get Google Maps Embed code for your business. To do it, find your business in Google Maps (1), click the Share button (2) and go to the Embed a map tab (3) in the popup window that comes up:

Copy the HTML code, and you’re good:

  1. Go to the Source tab of the widget’s settings in your Elfsight account and paste the code in the Google Place Address field. Click the Search button:


The results will be displayed below the search box. Click on the name of the business and its reviews will get displayed in the preview:

Please check it and let me know if it helped :slightly_smiling_face:

1 Like

Thanks for your suggestion, I found my Business on Google Maps and got the [Embed a Map] HTML and placed it in the source at Elfsight, still not found.

My Business is a Service Business, I dont have a physical office/location


Hi @R_Kaysar

I’ve added Embed code and all the reviews have been collected:

Could you please double-check it and let me know how it works?

Thank you, it worked!

Anyway I can remove the AI-Generated Summary?

1 Like

Happy to hear that you are good now :wink:

Sure thing, you can disable it by following these steps:

Thank you!

Do you know why my business doesnt show up in Google when searched?

Even Elfsight matched with a code when we pasted the HTML and didnt resolve the business name

1 Like

If you mean the search in our widget, this happens because your Business doesn’t have a physical address. In this way, you need to use Google Embed code. In this article you can find more details.

If you mean a global Google search, I’ve checked your business once again and it’s displayed now:

Previously, it was probably a temporary glitch on my side.