Creating a social feed - fb - page not showing

I am trying to create a new facebook feed and/or social feed.

The page owner has made me a “page manager”.

The page is not showing up in my page list on the dropdown.

I asked support if I needed to be a page admin, and the answer I got was:
“To connect a Facebook page to your widget, you need to be an administrator, editor, or moderator of the page.”

Apparently there is a different set of FB roles for pages now. You have “page access”, either with or without full control.

Do you need “full control” to have the page show in your list to add to a feed?

1 Like

Hi @Hugh :wave:

To display the page in the widget, you don’t need to enable Full Access option. You just need to add the required account to the People with Facebook access section and then accept this invitation.

If the page is still not available in the widget, please try to reconnect it. Click on Edit Settings and check if the required page is ticked:

Could you please double-check things and let me know if it helped?

I did this and it shows a whole list of pages that I have access to, but not this new one.

I don’t really want to disconnect and reconnect, because last time I did that all my other facebook feeds disconnected and I had to go in and manually re-add them.

I will do this though if that is my only option.

1 Like

Hi Hugh! I’m really sorry about this nuisance.

Could you please make sure that you’ve given us access to all the pages, including the one in question here: ?

I’ve also decided to consult our devs on the best solution and ask about the reconnect. I’ll get back to you when I’ve heard from them :slight_smile:


Hi @Hugh :wave:

Thank you for waiting!

I see that you’ve already talked to my colleague Eleonora and the issue seems to be resolved now.

As for the widget reconnect, our devs checked things and assured that reconnecting one widget won’t disconnect the others. This may happen only if you disconnect your widget and then change the settings of your Facebook page.

I hope this explains things.

If you have any further question, we are always here for you :slightly_smiling_face:

1 Like

This is the answer. You have to go to that link and add (by checking) any new pages you are now the manager of. Once I did this, the page appeared in my feed options. Thanks!