Contact Form Submit Button - 'Submit' text disappeared

The submit button in the contact form doesn’t show the word ‘submit’
I have tried custom code to change the colour and have not had any success

The website page with the form is below

Hello @user843 and we are happy to see you in Elfsight Community! Welcome :heart_hands:

I am terribly sorry for the inconvenience!

However, I am glad to inform you that we’ve fixed the issue!

Please check it and let me know if you like what you see :wink:

@Maksim I assume you know this bug is currently affecting all forms!

Definitely a top priority!!

1 Like

Hello @Hugh!

Thank you for contacting us!

Please accept my sincere apologies for any inconvenience caused!

At the moment, our devs are working on this issue and doing all their best to fix the issue as soon as possible!

Thank you for the understanding and prompt feedback!

Still not working

Hello @Reuben and welcome to Elfsight Community :wave:

We hasten to offer our sincere apologies for the inconvenience caused!

I understand how you feel, I’m terribly sorry.

I’ve checked your account and fixed your Contact Forms widgets locally.

However, I’d like to mention that, at the moment, our devs are doing all their best to fix the issue globally.

Could you please check your widgets and let me know if everything works fine on your side?

Dear Elfs,

Unfortunately, due to the recent update, our Form widgets are experiencing some technical difficulties that may result in issues with Submit Button’s display. Please accept my sincere apologies for the interruption in our app’s work.

We realize the urgency of the situation and how it can impact our customers, and our top priority is to fix the issue in the shortest possible time.

In the meanwhile, you can easily fix the issue by by manually refilling the text of the button: Settings tab Localisation Language Form Elements:

Thank you for your patience and understanding :pray:

2 Likes

I noticed my Submit buttons are all still a blank box so I came back to the forum and saw your post above. I went through 25 forms and manually typed Submit where it already says Submit. It seems to have worked. However I would suggest that this has not been a really satisfactory way to fix this, in the lack of notification about the workaround and of in terms of the time we had to take to implement the workaround.

You know I am a big supporter of Elfsight! But I suggest this situation could perhaps use an internal discussion.

1 Like

Hello @Hugh!

I am terribly sorry for the inconvenience it might have caused to you :pensive: Please accept my sincere apologies!

At the moment, our devs are working on this issue as a top priority and doing all their best to fix it in the nearest possible time.

Thank you for understanding and patience!

1 Like

Dear friends,

Just a little update on the issue.

The issue has been fixed for widgets with English language chosen in widget settings.

As for the other languages, our devs are still working on it and, hopefully, they’ll come up with a proper solution.

Thank you for your patience and understanding :pray: