Audio Player Upload Buttons Not Showing

Hello! I just went to manage my audio player and it’s no longer showing upload buttons for the audio file and for the photo. I tried several different things, but was not able to upload new audio. Please help as soon as possible. Thank you.


Hello @user2017! We are extremely happy that you joined us! Welcome to Elfsight Community :heart: :rocket:

I’ve checked your widget, tried to upload a track and everything seems to be working correctly:

Image upload works correctly too.

Could you please confirm if this is still an issue on your side?

If it is, please try to clear cache and cookies.

However, if the issue still persists, please provide me with a screenshot of the issue.

1 Like

Thank you for responding so quickly, Max! I just checked it on my end and neither Upload button is showing.
Looking at your pic, I see the upload button for photos but not for the audio file. That’s the one I really need.
Thank you.

1 Like

@user2017 I am terribly sorry for a not quite clear screenshot. There is no File upload button because I’ve already uploaded the track. Here is how it looked before uploading the file:

Could you please double-check it and let me know if everything is fine on your side?

1 Like

Still not showing up, and that’s checking on my phone and computer. I do appreciate you spending time working on this.


It’s not working for me either - no upload buttons for file or image.


@user2017 Please accept my deepest apologies for all the inconvenience caused!

We’ll be happy to check everything for you! Could you please provide me with the screenshot of the issue?

1 Like

Hello @user2027 and welcome to Elfsight Community :heart:

I am so sorry that you’ve encountered such an issue using our app :pensive:

We’ll be happy to check everything for you! Could you please provide us with the screenshot of the issue?

Hi Max, just checked again now and its working again. Something must have changed on your end. thanks


Great :fire:

I am happy to hear that you are good now!

If any questions come up, please feel free to contact us. We’ll be happy to help!

Have a nice day :wink:

Hi, Max! Thanks for checking back in with me. Here’s a screenshot from a few minutes ago, there’s another user who says they’re having the same problem.

1 Like

Hey @user2017

You don’t see the upload button because you’ve already uploaded files:

If you’d like to upload a new track, you need to click on Add button:


After that, you’ll be able to upload a new track:

Please let me know if this explains things or if you have any other questions

I used to be able to replace the file without creating a news one. Also, I tried adding a new file several times, as well as a new player with new files, and it looks the same - no upload buttons.

1 Like

@user2017 If you click on the uploaded file, you’ll be able to replace it with a new track:

If you delete the uploaded file, the upload button will appear again:

I hope this explains things.

If the issue still persists on your side, could you please provide me with the screencast of the issue? It would be tremendously helpful :pray:

1 Like

It’s finally fixed on my end. :slight_smile: Thank you very much for your help!!!


@user2017 I am happy to hear that you are good now!

If anything comes up, please do not hesitate to contact us!

Have a nice day :wink:


1 Like